Definition Lists not working properly in the templates.

A place to ask questions and get help. Be the first on your block to post ...

Definition Lists not working properly in the templates.

Postby mmesarch1 » Thu Aug 10, 2006 10:28 am

Hi,
I am trying to use a definition list, which I have used a lot before.
Something in the templates is causing a problem not only with displaying the definition list, but is causing Dreamweaver to incorrectly allow definition listed to be created.

First I created a page called http://nfs.unl.edu:9112/testlistwithtemplate.asp
using the fixed template. I created a stanard unordered list. Works fine. But as I created a definition list the "definition" part which is suppose to be indented is not. (tag <dd>) But then I noticed as I was using Dreamweaver 8 what is suppose to happened was not either. When this list is being created the first part, the "word" ( tag <dt>) is not indented and then when you press Return the next line should be ready for the "definition" (tag<dd>) but Dreamweaver is actually putting another <dd> tag. I corrected the list and made the defintions the appropriate tags and the words the appropriate tags. Still the resulting live page is wrong.

So next I created a page without the templates called http://nfs.unl.edu:9112/testlistwithouttemplate.html
First I cut and pasted the contents of the testlistwithouttemplate.asp body area into the file and the result looked correct. Secondly I created another definition list in this file the way I normally used Dreamweaver and it worked fine.

Any ideas? I used the definition list extensively in some of the other sites I will need tranfer to the NEW templates.

BTW.. I just downloaded the new templates yesterday and also updated the dependent files on my website too, so I should have the newest files.
Thanks
Last edited by mmesarch1 on Thu Aug 10, 2006 4:05 pm, edited 1 time in total.
mmesarch1
 
Posts: 105
Joined: Wed May 11, 2005 1:48 pm
Location: 229D Hardin Hall

Postby saltybeagle » Fri Aug 11, 2006 5:05 am

First things first... the dd left padding has been fixed in cvs. You should see it next time you synchronize the templatedependents.

The splashnav styling applied to dl's is in the queue... we'll look at it when we get a chance.
Brett Bieber
Image
saltybeagle
 
Posts: 376
Joined: Fri Jan 16, 2004 3:10 pm
Location: 321 Admin


Return to Help & Assistance

Who is online

Users browsing this forum: No registered users and 2 guests

cron