I need help setting up templates on an OS X Server

A place to ask questions and get help. Be the first on your block to post ...

I need help setting up templates on an OS X Server

Postby yesdude » Fri May 18, 2007 8:01 pm

I'm trying to setup the UNL templates on my own server. I have mirrored the files into the ucomm folder inside the root directory.


I have created this file:
which makes use of the secure php template. However, looking through the code, none of the php virtual() functions seem to be working correctly.

Originally I received the following message:
Warning: virtual() [function.virtual]: Unable to include '/ucomm/templatedependents/templatesharedcode/includes/browsersniffers/ie.html' - error finding URI in /Volumes/WEB/test/index.php on line 11

There were similar messages at every occurrence of a php virtual() command. So I tried replacing the virtual() functions with include() making sure to give permissions 755 to the files and to make sure the URLs were absolute and not relevant. Upon testing, the PHP errors were gone, however the template styles and other files did not appear to be included. Note: I'm certain that there isn't anything wrong with including files on my end, because the following code in my file works absolutely fine:

Code: Select all
      <div id="nav_end">
        <div id="leftcollinks">
          <h3>Related Links</h3>
          <?php include('sharedcode/relatedLinks.html'); ?>

Finally, I double checked my httpd.conf file to make sure that SSI was enabled. The following are located in my httpd.conf file:

Code: Select all
AddHandler server-parsed shtml
AddType text/html shtml

        <Directory "/Volumes/WEB">
                Options All +Indexes +Includes +MultiViews +ExecCGI
                        DAV Off
                AllowOverride None

As you can see, I believe that my server is ready to use the templates, however, that is not the case.

At this point I thought that there might have been some error in my page's code and use of the template, so I uploaded it to my CSE account:
(Use Firefox or IE)

As you can see however, that an error in my page's code is not the case as it works fine on CSE.

Finally I resorted to examining the files I downloaded from

If you look the templatedependents directory, it doesn't contain a copy of templatesharedcode. Noticing this, I copied templatedependents_bak and renamed it to templatedependents appropriately. This however, did not fix the problem. The feeling I'm getting, is that the templates located in ftp://wdn:1869@ucommdev.unl.edu are not functionally correct, or that there is something horribly wrong on my server. If someone could assist me in setting up the templates on my end, I would appreciate it.

Some information of my server can be located here:
(I will be taking this file down soon)

I know there are some xhtml and css validation errors, but ignore that for now.

Thanks in advance.
Last edited by yesdude on Sun May 20, 2007 2:50 am, edited 2 times in total.
Posts: 2
Joined: Fri May 18, 2007 6:36 pm

Postby saltybeagle » Sat May 19, 2007 7:04 am

Try updating the templatedependents from the ftp site again, or copy the files from cse - you don't have a full copy.

Please do not comment on my modification of the templates as they are being used by one of our departments exclusively, and will not be available to the public

"I'm using the code how I want, so the WDN's terms of use don't apply to me" ?

Brett Bieber
Posts: 376
Joined: Fri Jan 16, 2004 3:10 pm
Location: 321 Admin

Postby yesdude » Sat May 19, 2007 8:39 am

Thank you for your assistance. As you can see from the images below, until about an hour ago, the templatedependents/templatesharedcode was not present from the ftp site when accessed by three of my servers. Furthermore, after copying the files from the ftp site, the errors persisted. Copying them from CSE however, solved the problem. I can continue using the templates I downloaded from CSE however, I would like to know why the FTP site's copy might not be working correctly on my server (I noticed it was updated recently 05/17).

In response to the modification of the template, I will need to review the Terms of Use with my managers.

Image Image
Posts: 2
Joined: Fri May 18, 2007 6:36 pm

Return to Help & Assistance

Who is online

Users browsing this forum: No registered users and 1 guest