Validation Errors

A place to ask questions and get help. Be the first on your block to post ...

Validation Errors

Postby mwolfe1 » Thu Jun 25, 2009 10:15 am

How do I fix the errors on my webpage: www.unl.edu/armyrotc/inquiry.shtml?

Also, is there a way to bring the submission requests into Access or Excel?
mwolfe1
 

Postby acoleman » Thu Jun 25, 2009 11:55 am

The best way to find out what errors are happening is to click the little "W3C" tag in the footer of your page. From there, make sure you have the "show source" box ticked in the Options area when you try to validate the page, as that will give a good idea where the problems are.

Stepping through them...

1) Line 361, Column 108: required attribute "alt" not specified

All images need an alt="" tag in order to identify what the image is. To fix yours, just add an alt tag such as the following into your image tag:

Code: Select all
<img src="images/Cadre/Murdock.jpg" width="158" height="210" alt="1LT Spencer Murdock" />


2) Line 550, Column 27: document type does not allow element "td" here

For this one, it just looks like you have a table column defined without any table around it. I think it will work if you change the code to read:

Code: Select all
<p>&nbsp;</p>
<table>
<tr>
<td>
<input type="hidden" name="whither" value="goldbar@unl.edu" />
</td>
</tr>
</table>


3) Line 551, Column 69: end tag for "input" omitted, but OMITTAG NO was specified

See the change I made in the input tag above. It just needed to be closed.

There's one more error, but I'm not quite sure what it is yet. If you make the aforementioned changes and re-validate it, I could probably help figure it out.
acoleman
 
Posts: 48
Joined: Tue Sep 20, 2005 2:54 pm
Location: 321 Canfield


Return to Help & Assistance

Who is online

Users browsing this forum: No registered users and 1 guest

cron