Validation of Media Hub movies

Notes on the visual redesign process

Validation of Media Hub movies

Postby dsockrider » Tue Mar 30, 2010 2:38 pm

I wanted to embed some movies from the Media Hub into some Engineering web pages. I put the embed code in the page, but it doesn't validate.

The original Media Hub page doesn't validate either.
http://www1.unl.edu/mediahub/media/1031

How can we embed movies from the Media Hub so that pages validate?

I guess I could download the .mp4, run through the Flash Compressor, and re-embed... but it'd be nice if the provided embed code just validated.
dsockrider
 
Posts: 189
Joined: Fri Dec 16, 2005 10:37 am
Location: Engineering

Postby CanadianSuperSpy » Wed Mar 31, 2010 12:56 pm

the provided embed code:
Code: Select all
<object height="408" width="640">
   <param name="allowfullscreen" value="true"></param>
   <param name="allowscriptaccess" value="always"></param>
   <param name="wmode" value="transparent"></param>
   <embed src="http://www.unl.edu/ucomm/templatedependents/templatesharedcode/scripts/components/mediaplayer/player.swf?file=http://ucomm.unl.edu/av/video/pyotm/ZNETprojectPYOTM.mp4&amp;image=http://itunes.unl.edu/thumbnails.php?url=http%3A%2F%2Fucomm.unl.edu%2Fav%2Fvideo%2Fpyotm%2FZNETprojectPYOTM.mp4&amp;volume=100&amp;autostart=false&amp;skin=http://www.unl.edu/ucomm/templatedependents/templatesharedcode/scripts/components/mediaplayer/UNLVideoSkin.swf" type="application/x-shockwave-flash" allowscriptaccess="always" wmode="transparent" allowfullscreen="true" height="408" width="640">
   </embed>
</object>


Should be:
Code: Select all
<object height="408" width="640" type="application/x-shockwave-flash" data="http://www.unl.edu/ucomm/templatedependents/templatesharedcode/scripts/components/mediaplayer/player.swf">
   <param name="movie" value="http://www.unl.edu/ucomm/templatedependents/templatesharedcode/scripts/components/mediaplayer/player.swf" />
   <param name="allowfullscreen" value="true" />
   <param name="allowscriptaccess" value="always" />
   <param name="wmode" value="transparent" />
   <param name="FlashVars" value="file=http://ucomm.unl.edu/av/video/pyotm/ZNETprojectPYOTM.mp4&amp;image=http://itunes.unl.edu/thumbnails.php?url=http%3A%2F%2Fucomm.unl.edu%2Fav%2Fvideo%2Fpyotm%2FZNETprojectPYOTM.mp4&amp;volume=100&amp;autostart=false&amp;skin=http://www.unl.edu/ucomm/templatedependents/templatesharedcode/scripts/components/mediaplayer/UNLVideoSkin.swf" />
</object>


http://isaac.unl.edu/flash/
CanadianSuperSpy
 
Posts: 17
Joined: Wed Jul 23, 2008 1:22 pm
Location: CBA Room 13

Postby smeranda » Wed Mar 31, 2010 3:59 pm

Seth Meranda
User Experience Architect
University Communications
(402) 472-8513
seth@unl.edu
smeranda
 
Posts: 111
Joined: Tue Apr 05, 2005 2:34 pm
Location: University Communications

Postby dsockrider » Thu Apr 08, 2010 12:10 pm

I just downloaded the file, ran through the Flash converter and used code that validates.
dsockrider
 
Posts: 189
Joined: Fri Dec 16, 2005 10:37 am
Location: Engineering

Postby bbieber2 » Mon Apr 12, 2010 1:26 pm

All that is needed is for someone to commit a fix to the media hub project page. This file is the one that needs the changes:

www/templates/html/Media.tpl.php

http://its-gforge.unl.edu/gf/project/un ... iew=markup

Would someone be kind enough contribute a fix?
bbieber2
 
Posts: 58
Joined: Mon Nov 05, 2007 1:28 pm

Postby smeranda » Mon Apr 12, 2010 2:45 pm

Fixed and committed.
Seth Meranda
User Experience Architect
University Communications
(402) 472-8513
seth@unl.edu
smeranda
 
Posts: 111
Joined: Tue Apr 05, 2005 2:34 pm
Location: University Communications


Return to Visual Redesign

Who is online

Users browsing this forum: No registered users and 0 guests

cron