Javascript/all.js issue with Internet Explorer 7 and 8?

A place to ask questions and get help. Be the first on your block to post ...

Javascript/all.js issue with Internet Explorer 7 and 8?

Postby mjoconnor » Tue Mar 16, 2010 11:59 am

Hi,

We've had a Javascript-powered slideshow on our homepage that has been working until a couple weeks ago and the error message in IE7 and sometimes IE8 points to all.js. The navigation links don't work. When I comment out the slideshow, everything works fine.

I put the original page here: http://ascweb.unl.edu/index-debug.aspx It validates when I click W3C.

This has only affected this page. I have the slideshow on other pages and those work fine. There is extra Javascript powering RSS feeds here.

I don't know how to use debug.dwt to debug it. I thought I would see if there have been recent changes to all.js that would affect other Javascript.

My own IE8 works fine, and some others work and some don't. IE7 hasn't worked for other people. Using compatibility view doesn't seem to help. Version number doesn't seem to matter, nor does having all Windows updates done.

Firefox and Chrome don't have issues.

Any ideas? Thanks!
mjoconnor
 
Posts: 16
Joined: Fri May 16, 2008 11:56 am

Postby smeranda » Thu Apr 15, 2010 11:47 am

I'm not able to replicate the issue in either IE7 or IE8. You mentioned the only difference between this page (in terms of JS usage) is the RSS feeds. Perhaps one of your RSS feeds had invalid characters?
Seth Meranda
User Experience Architect
University Communications
(402) 472-8513
seth@unl.edu
smeranda
 
Posts: 111
Joined: Tue Apr 05, 2005 2:34 pm
Location: University Communications

JS issue resolved

Postby mjoconnor » Thu Apr 15, 2010 1:24 pm

I apologize for not posting sooner that this was resolved - apparently it was a missing 'title' element produced by aspx that caused the IE issue. I'm surprised it didn't happen sooner, but Isaac in CBA was able to take care of it.

Thanks anyway! Mike
mjoconnor
 
Posts: 16
Joined: Fri May 16, 2008 11:56 am


Return to Help & Assistance

Who is online

Users browsing this forum: No registered users and 2 guests

cron