jQuery error in template?

Information and discussion on Javascript.

Moderators: rcrisler1, saltybeagle

jQuery error in template?

Postby s-schakra3 » Thu Aug 12, 2010 12:05 pm

So it keeps showing as a jQuery error in firebug and the tab switching doesn't work.

http://nmc-server1.unl.edu/sourabh_designcenter2/form.php

Error: WDN.jQuery(this).children("a").attr("href") is undefined

I'm not using the Dreamweaver template to write the code. I'm using the php script suggested by Tim (Steiner) instead.

require_once 'UNL/Templates.php';

Unl_Templates::$options['version'] = UNL_Templates::VERSION3;
$template = UNL_Templates::factory('Fixed');

Dunno if using it like this is doing something different. Because I've implemented tabs using unl template before (when using D'weaver templates) and it works fine.

Thanks a bunch !
Sourabh
(New Media Center, UNL)
s-schakra3
 
Posts: 7
Joined: Sat Oct 04, 2008 2:52 pm

clarification

Postby s-schakra3 » Thu Aug 12, 2010 2:29 pm

On doing some investigation, I noticed the all.js file that the template I'm using is version 1239 2010-06-29.

And the all.js file that exists in the wdn folder downloadable from the website wdn.unl.edu/downloads is of an earlier version from March, 1095 2010-03-26.

So it might be something in the new all.js file because I see the tabs has been implemented differently.
s-schakra3
 
Posts: 7
Joined: Sat Oct 04, 2008 2:52 pm

solved

Postby s-schakra3 » Thu Aug 12, 2010 4:33 pm

Sigh. If life doesn't get any more embarrassing than this. So it was a <li> instead of a </li> that was the culprit.

Yes, I'm resigning from web development after this debacle.
s-schakra3
 
Posts: 7
Joined: Sat Oct 04, 2008 2:52 pm


Return to Javascript

Who is online

Users browsing this forum: No registered users and 0 guests

cron